Service is unavailable
Incident Report for Snappy Gifts
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 17:53 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 14, 2020 - 17:08 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 14, 2020 - 16:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 14, 2020 - 16:15 UTC
Investigating
We are currently investigating this issue.
Posted Jul 14, 2020 - 16:13 UTC
This incident affected: Dashboard.