Service Disruption
Incident Report for Snappy Gifts
Resolved
This incident has been resolved.
Posted Apr 06, 2022 - 11:48 UTC
Investigating
We are currently experiencing a service disruption and our engineering team is working to identify the root cause and implement a solution. Some users may be affected.
Posted Apr 06, 2022 - 04:03 UTC
This incident affected: Dashboard and API.